Re: How to download files with a "#" in file name

Frans Beyl

But then I don't use ml, you might try without it.

Op za 24 jul. 2021 om 19:53 schreef Frans Beyl <frans.beyl@...>

Strange, I just tested and download is fine for all members also one starting with # 

Op vr 23 jul. 2021 om 18:08 schreef ajit.rsahu via <>
Thank you Very much Dan for looking into this .  I tried your command as well. But its failing with same error. 

My Command : 
zowe zos-files download all-members "DatasetName" -b -d "DirectoryLocation"

Error Message :

Rest API failure with HTTP(S) status 404
category: 1
rc:       4
reason:   3
message:  DatasetName(
Error Details:
HTTP(S) error status "404" received.
Review request details (resource, base path, credentials, payload) and ensure correctness.
Protocol:  https
Host:      host
Port:      port
Base Path: basepath
Resource:  /zosmf/restfiles/ds/DatasetName(member1)
Request:   GET
Headers:   [{"X-IBM-Data-Type":"binary"},{"Accept-Encoding":"gzip"},{"X-IBM-Response-Timeout":"500"},{"X-CSRF-ZOSMF-HEADER":true}]
Payload:   undefined


Join { to automatically receive all group messages.