Re: Zowe Help for installation on LPAR4


Sean Grady
 

Hi Fabio.
Yes, having empty folders there is going to cause problems. I saw this once before and I think it was because a user used a pax archive, but had either missing environment variables or missing flags, maybe both.
For all downloads, make sure you have "_BPKX_AUTOCVT=on" in your environment. You could do this manually by "export _BPKX_AUTOCVT=on" in a shell or in the .profile file in your users home directory to have that option persist. Its used to handle file tagging.

For a pax download, make sure to do
pax -ppx -rf zowe-archive-name.pax

Which will extract it into the folder you are in.
If those two tips dont result in having all files there & correct, then I bet there will be some output from the unpax or zowe-install.sh steps that would be useful for us to see in order to know the reason why files are missing.

As for the desktop, in your zowe instance folder, check for the logs directory, which will have appServer log files. Within, you may see an error "ZWED0171W". If you do, it means the desktop is breaking due to a security policy that needs configuration. Just take whatever hosts or ips you use in your browser to get to the desktop, and enter this into instance.env file:
ZWE_REFERRER_HOSTS=myip,myhost,myip2
It can be a whole list, if your system is accessible in more than one way. We try to capture a series of defaults, but sometimes this explicit configuration is needed. The change would be seen after restarting zowe.

Sean Grady

Senior Software Architect

Rocket Software

77 Fourth Avenue • Waltham, MA, 02451-1466 • USA

t: +1 781 684 2022 • e: sgrady@... • w: www.rocketsoftware.com



From: zowe-user@... <zowe-user@...> on behalf of Fabio Andres Carmona via lists.openmainframeproject.org <fcarmona=gbm.net@...>
Sent: Monday, June 21, 2021 6:56 PM
To: Zowe-user@... <Zowe-user@...>
Subject: [zowe-user] Zowe Help for installation on LPAR4
 
EXTERNAL EMAIL




Good morning ZOWE team,

 

I´m having some problems in my installation of ZOWE 1.19.0, first I ran all scripts from the convenience build successfully.

When I tried to verify the access to the ZOWE DESKTOP url: https://myhost:httpsPort, I check that I could get the page, but I  got this problem of authentication:

Later, when I tried to verify the access to the API Mediation Layer url: https://myhost:gatewayPort/api/v1/apicatalog/application/health, I couldn´t reach the page, I got the following:

 

After looking through many troubleshooting, I changed my default authenticator from “SAF” to “ZSS”, followings all the steps mentioned in https://docs.zowe.org/stable/user-guide/mvd-configuration.html#multi-factor-authentication-configuration. With this change made, I could access to zowe desktop but some of the plugins weren´t running, other have some issues with permission denied, this is an example, i got this messages:

 

 

During my investigation I found that the following address space weren´t running, and the respective ports weren´t listening:

  • AC - API ML Catalog,  7552
  • AD - API ML Discovery Service,  7553
  • AG - API ML Gateway, 7554
  • EF - Explorer API Data Sets,  8547
  • EJ - Explorer API Jobs, 8545

Looking in my installation logs and many troubleshooting and issues from GITHUB and SLACK, I found that folders in <RUNTIME_DIR>/components were empty, look this picture:

So I decided, to begin a new installation of ZOWE 1.20.1, in this case I used workflows to complete all configurations. But in this opportunity I checked in the step were the runtime folder its created, to verify the folders from the component folder, and again some of them were empty. So, I downloaded to my computer the ZIP files from installation folder (api-catalog,apiml-common-lib, caching-service, discovery, gateway and jobs-api folders), next I unzipped those folders and copied them back, via FTP, to the component folders of the ZOWE 1.20.1. And then, I continued all the process of the installation.

When finished, I tried again to reach the below links, to verify the installation:

ZOWE DESKTOP url: https://myhost:httpsPort   à Successful with Authorizathor “ZSS”

API Mediation Layer url: https://myhost:gatewayPort/api/v1/apicatalog/application/healthàUNSucessful

In this new installation, the following address spaces didn´t started:

  • AC - API ML Catalog,  7552
  • AD - API ML Discovery Service,  7553
  • AG - API ML Gateway, 7554
  • EF - Explorer API Data Sets,  8547
  • EJ - Explorer API Jobs, 8545
  • UD - Explorer UI Data Sets, 8548            
  • UU - Explorer UI USS, 8550

I verified in the instance.env and check that all parameters where OK, the LAUNCH_COMPONENT_GROUP=DESKTOP,GATEWAY, were verified.         

All the range from 8542-8550, 7552-7555, 22,23,443 were open to the firewall.

My Hostname is: “”icetel4.ice.go.cr””

Here you will find attached the installation log, zssServer log and appServer log from the ZOWE 1.19.1 and ZOWE-1.20.1 installation, for you can check them.

IF you need further information, we’ll be a pleasure to send it to you.

If you can notice something that I went wrong, or may be some tips and tricks I will appreciate all kind of help.

Best Regards.

Fabio A. Carmona Rojas

COE Z Enginner
GBM Corporation
Tel: +506 2284-3999 Ext. 6707
Email: fcarmona@...
GBM as a Service 
GBM | Facebook

 

================================
Rocket Software, Inc. and subsidiaries ■ 77 Fourth Avenue, Waltham MA 02451 ■ Main Office Toll Free Number: +1 855.577.4323
Contact Customer Support: https://my.rocketsoftware.com/RocketCommunity/RCEmailSupport
Unsubscribe from Marketing Messages/Manage Your Subscription Preferences - http://www.rocketsoftware.com/manage-your-email-preferences
Privacy Policy - http://www.rocketsoftware.com/company/legal/privacy-policy
================================

This communication and any attachments may contain confidential information of Rocket Software, Inc. All unauthorized use, disclosure or distribution is prohibited. If you are not the intended recipient, please notify Rocket Software immediately and destroy all copies of this communication. Thank you.

Join zowe-user@lists.openmainframeproject.org to automatically receive all group messages.