Zowe Help for installation on LPAR4


Fabio Andres Carmona
 

Good morning ZOWE team,

 

I´m having some problems in my installation of ZOWE 1.19.0, first I ran all scripts from the convenience build successfully.

When I tried to verify the access to the ZOWE DESKTOP url: https://myhost:httpsPort, I check that I could get the page, but I  got this problem of authentication:

Later, when I tried to verify the access to the API Mediation Layer url: https://myhost:gatewayPort/api/v1/apicatalog/application/health, I couldn´t reach the page, I got the following:

 

After looking through many troubleshooting, I changed my default authenticator from “SAF” to “ZSS”, followings all the steps mentioned in https://docs.zowe.org/stable/user-guide/mvd-configuration.html#multi-factor-authentication-configuration. With this change made, I could access to zowe desktop but some of the plugins weren´t running, other have some issues with permission denied, this is an example, i got this messages:

 

 

During my investigation I found that the following address space weren´t running, and the respective ports weren´t listening:

  • AC - API ML Catalog,  7552
  • AD - API ML Discovery Service,  7553
  • AG - API ML Gateway, 7554
  • EF - Explorer API Data Sets,  8547
  • EJ - Explorer API Jobs, 8545

Looking in my installation logs and many troubleshooting and issues from GITHUB and SLACK, I found that folders in <RUNTIME_DIR>/components were empty, look this picture:

So I decided, to begin a new installation of ZOWE 1.20.1, in this case I used workflows to complete all configurations. But in this opportunity I checked in the step were the runtime folder its created, to verify the folders from the component folder, and again some of them were empty. So, I downloaded to my computer the ZIP files from installation folder (api-catalog,apiml-common-lib, caching-service, discovery, gateway and jobs-api folders), next I unzipped those folders and copied them back, via FTP, to the component folders of the ZOWE 1.20.1. And then, I continued all the process of the installation.

When finished, I tried again to reach the below links, to verify the installation:

ZOWE DESKTOP url: https://myhost:httpsPort   à Successful with Authorizathor “ZSS”

API Mediation Layer url: https://myhost:gatewayPort/api/v1/apicatalog/application/healthàUNSucessful

In this new installation, the following address spaces didn´t started:

  • AC - API ML Catalog,  7552
  • AD - API ML Discovery Service,  7553
  • AG - API ML Gateway, 7554
  • EF - Explorer API Data Sets,  8547
  • EJ - Explorer API Jobs, 8545
  • UD - Explorer UI Data Sets, 8548            
  • UU - Explorer UI USS, 8550

I verified in the instance.env and check that all parameters where OK, the LAUNCH_COMPONENT_GROUP=DESKTOP,GATEWAY, were verified.         

All the range from 8542-8550, 7552-7555, 22,23,443 were open to the firewall.

My Hostname is: “”icetel4.ice.go.cr””

Here you will find attached the installation log, zssServer log and appServer log from the ZOWE 1.19.1 and ZOWE-1.20.1 installation, for you can check them.

IF you need further information, we’ll be a pleasure to send it to you.

If you can notice something that I went wrong, or may be some tips and tricks I will appreciate all kind of help.

Best Regards.

Fabio A. Carmona Rojas

COE Z Enginner
GBM Corporation
Tel: +506 2284-3999 Ext. 6707
Email: fcarmona@...
GBM as a Service 
GBM | Facebook

 

Join zowe-user@lists.openmainframeproject.org to automatically receive all group messages.